Skip to main content
Warning: You are using the test version of PyPI. This is a pre-production deployment of Warehouse. Changes made here affect the production instance of TestPyPI (testpypi.python.org).
Help us improve Python packaging - Donate today!

A wrapper for interacting with the CLU Lab's processors library.

Project Description
[![Documentation Status](https://readthedocs.org/projects/py-processors/badge/?version=latest)](http://py-processors.readthedocs.io/en/latest/?badge=latest) [![Build Status](https://travis-ci.org/myedibleenso/py-processors.svg?branch=master)](https://travis-ci.org/myedibleenso/py-processors) [![Scrutinizer Code Quality](https://scrutinizer-ci.com/g/myedibleenso/py-processors/badges/quality-score.png?b=master)](https://scrutinizer-ci.com/g/myedibleenso/py-processors/?branch=master) [![Coverage Status](https://coveralls.io/repos/github/myedibleenso/py-processors/badge.svg?branch=master)](https://coveralls.io/github/myedibleenso/py-processors?branch=master) [![Requirements Status](https://requires.io/github/myedibleenso/py-processors/requirements.svg?branch=master)](https://requires.io/github/myedibleenso/py-processors/requirements/?branch=master) [![Stories in Ready](https://badge.waffle.io/myedibleenso/py-processors.svg?label=ready&title=Ready)](http://waffle.io/myedibleenso/py-processors)

# Contents
- [Text processors](processors.md)
- [Rule-based IE with Odin](odin.md)
- [Annotating text](processors.md#annotating-text)
- [A walkthrough example](example.md)
- [Running the tests](dev.md#running-the-tests)
- [FAQ](faq.md)
- [History](release-notes.md)

# What is it?
`py-processors` is a Python wrapper for the CLU Lab's [`processors`](http://github.com/clulab/processors) NLP library. `py-processors` relies on [`processors-server`](http://github.com/myedibleenso/processors-server).

Though [compatible*](https://github.com/myedibleenso/py-processors/issues?q=is%3Aopen+is%3Aissue+label%3Apython2.x) with Python 2.x, this library was developed with 3.x in mind.

# Requirements
- [Java 8](https://docs.oracle.com/javase/8/docs/technotes/guides/install/install_overview.html)
- [`processor-sever`](http://github.com/myedibleenso/processors-server) (v2.7)
- this dependency will be retrieved automatically during installation
- At least 2GB of RAM free for the server (I recommend 3GB)

# Installation

```bash
pip install git+https://github.com/myedibleenso/py-processors.git
```

# How to use it?

See [the walkthrough example](example.md#a-walkthrough-example)
Release History

Release History

This version
History Node

2.8

Supported By

WebFaction WebFaction Technical Writing Elastic Elastic Search Pingdom Pingdom Monitoring Dyn Dyn DNS Sentry Sentry Error Logging CloudAMQP CloudAMQP RabbitMQ Heroku Heroku PaaS Kabu Creative Kabu Creative UX & Design Fastly Fastly CDN DigiCert DigiCert EV Certificate Rackspace Rackspace Cloud Servers DreamHost DreamHost Log Hosting